Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:

Issues with Cloudflare Dashboard for Mobile Users

Incident Report for Cloudflare

Resolved

An effective fix for this issue was implemented. This issue is now resolved.
Posted Feb 19, 2025 - 19:31 UTC

Identified

We have identified an issue where a subset of users are not able to interact with the Cloudflare Dashboard on mobile devices. We are working on a fix for this issue.
Posted Feb 19, 2025 - 19:01 UTC
This incident affected: Cloudflare Sites and Services (Dashboard).