Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Network Performance Issues in Manila
Incident Report for Cloudflare
Resolved
This incident is now resolved.
Posted Dec 16, 2024 - 17:55 UTC
Monitoring
The cause of this issue was identified and a fix was implemented. We are currently monitoring the results.
Posted Dec 16, 2024 - 17:48 UTC
Investigating
Cloudflare is investigating issues with Network Performance in our Manila (MNL) datacenter.

We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Dec 16, 2024 - 17:44 UTC
This incident affected: Asia (Manila, Philippines - (MNL)).