Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Workers Builds - Build Issues
Incident Report for Cloudflare
Resolved
An effective fix has been implemented and this issue is now resolved.
Posted Jan 21, 2025 - 22:46 UTC
Identified
The cause of this issue has been identified and a fix is being implemented.
Posted Jan 21, 2025 - 22:29 UTC
Investigating
Cloudflare is investigating an issue where Workers Builds builds are failing. We will provide further updates shortly.
Posted Jan 21, 2025 - 22:13 UTC
This incident affected: Cloudflare Sites and Services (Workers).