Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.
Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.
A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2024 - 02:21 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 29, 2024 - 01:20 UTC
Identified
The cause of this issue has been identified and a fix is being implemented.
Posted Oct 28, 2024 - 23:23 UTC
Investigating
We are currently investigating an issue where a small number of requests to Turnstile get a "400" status code with the body "invalid-sitekey", resulting in a broken Turnstile widget.
Posted Oct 28, 2024 - 23:17 UTC
This incident affected: Cloudflare Sites and Services (Turnstile).