Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Connectivity issue with WARP client 2024.11.143.0 on macOS
Incident Report for Cloudflare
Resolved
Cloudflare released a WARP Client update on 2024-11-11 for Linux, macOS, and Windows. Due to reports from several customers that a portion of their fleets could not connect to WARP after upgrading to this new version, a decision was made on 2024-11-12 at 15:39 to pull the problematic macOS GA build (2024.11.143.0). Windows and Linux releases are not affected by this.

Customers are advised to revert to the previous stable release (2024.9.346.0) if they experience issues with macOS devices unable to connect.
Posted Nov 11, 2024 - 22:00 UTC