Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Issue with DLP Dashboard
Incident Report for Cloudflare
Resolved
An effective fix for this issue was identified and implemented. This issue is now resolved.
Posted Dec 17, 2024 - 21:03 UTC
Investigating
Cloudflare is investigating issues with the DLP portion of the Zero Trust dashboard.
Posted Dec 17, 2024 - 20:12 UTC
This incident affected: Cloudflare Sites and Services (Zero Trust Dashboard).