Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
HTTP 500 errors when modifying DNS records, Pages projects, Workers subdomains
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Dec 05, 2024 - 18:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2024 - 18:17 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 05, 2024 - 18:13 UTC
Investigating
Cloudflare is investigating reports of HTTP 500 errors when modifying or querying DNS records via the Cloudflare API, creating new Pages projects, and creating or changing Workers subdomains.
Posted Dec 05, 2024 - 18:11 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates, Pages, Workers).