Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:

New Workers Cron Triggers Schedules Are Not Running

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Feb 19, 2025 - 18:27 UTC

Monitoring

We have identified the cause of this issue and have implemented a fix. We are currently monitoring the results.
Posted Feb 18, 2025 - 22:39 UTC

Investigating

We are investigating an issue where new cron schedules created via Wrangler, Dash, or API since 2025-02-18 20:42 UTC have not run as expected. We are also investigating if this has impacted any currently active schedules.
Posted Feb 18, 2025 - 22:26 UTC
This incident affected: Cloudflare Sites and Services (Workers).