Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Issues with Cloudflare Calls SFU service
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 28, 2024 - 19:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 28, 2024 - 19:20 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 28, 2024 - 15:40 UTC
Investigating
Starting yesterday at 2:40 UTC, Cloudflare became aware of and is investigating an issue with our Cloudflare Calls service, which potentially impacts multiple customers.
A fix is now being deployed, and Cloudflare Calls TURN is not impacted.
Posted May 28, 2024 - 15:37 UTC
This incident affected: Cloudflare Sites and Services (Calls).