Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Increased HTTP 525 Errors in India
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 28, 2024 - 13:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 28, 2024 - 12:58 UTC
Investigating
Cloudflare is investigating an increased level of HTTP 525 errors occurring on specific datacenters in India.

We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted May 28, 2024 - 12:41 UTC
This incident affected: Asia (Bangalore, India - (BLR), Chennai, India - (MAA), Hyderabad, India - (HYD), Kolkata, India - (CCU), New Delhi, India - (DEL), Kannur, India - (CNN)).