Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Error message when upgrading a domain to the Enterprise plan
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jul 18, 2024 - 13:42 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2024 - 13:22 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 18, 2024 - 12:46 UTC
Investigating
Cloudflare is aware of, and investigating an issue on which customers might see an error code 500 or 1000 with "Internal Server Error" message when upgrading a domain to Enterprise plan.
Further detail will be provided as more information becomes available.
Posted Jul 18, 2024 - 12:33 UTC
This incident affected: Cloudflare Sites and Services (Billing).