Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Network Performance Issues in Singapore
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 01, 2024 - 18:20 UTC
Identified
Cloudflare is investigating issues with Network Performance in Singapore.

We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Jun 01, 2024 - 17:29 UTC
This incident affected: Cloudflare Sites and Services (Network).