Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.
Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.
A fix has been implemented and we are monitoring the results.
Some customers may have experienced higher latency around these datacenters: Tallinn (TLL) Rome (FCO) Berlin (TXL) Zagreb (ZAG) Kyiv (KBP) Copenhagen (CPH)
Posted Oct 26, 2024 - 06:55 UTC
Update
We are continuing to investigate this issue.
Posted Oct 26, 2024 - 06:29 UTC
Investigating
Cloudflare is investigating issues with Network Performance
We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Oct 26, 2024 - 06:27 UTC
This incident affected: Cloudflare Sites and Services (Network).