Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Network Route Leak
Incident Report for Cloudflare
Resolved
Cloudflare was affected by a route leak, impacting performance for some customers in Europe. This may have lead to higher latency or timeouts between 08:30 and 09:30 UTC.
Posted Dec 13, 2024 - 08:30 UTC