Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Elevated number of 500 errors on Pages assets
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 10, 2024 - 19:23 UTC
Update
We have mitigated impact for all new deployments created with Pages CI/CD.

Users that are on wrangler version 3.60.0 should update to wrangler version 3.60.1 and re-deploy their Pages project in order to resolve 500 errors.
Posted Jun 10, 2024 - 19:15 UTC
Monitoring
We have mitigated impact for all new deployments created with Pages CI/CD.

Users that are on wrangler version 3.60.0 and are running wrangler pages deploy for Pages projects with > 1000 assets will still be impacted by this bug. A new version of wrangler will be available shortly.
Posted Jun 10, 2024 - 18:55 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 10, 2024 - 18:19 UTC
Investigating
We are investigating reports of elevated HTTP 500 error rates for some new deployments created on Cloudflare Pages.

If you are impacted by elevated HTTP 500 error rates to your Pages project, performing a rollback the previous deployment will remedy the issue.
Posted Jun 10, 2024 - 16:47 UTC
This incident affected: Cloudflare Sites and Services (Pages).