Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Some Low Cache TTL values not being respected
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 04:47 UTC
Identified
Cloudflare has identified an issue with Low Edge Cache TTL during assets revalidation. Cached requests TTL might intermittently not be respected.
Posted Jan 13, 2025 - 20:15 UTC
This incident affected: Cloudflare Sites and Services (CDN/Cache).