Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
CDN mTLS certificate issue
Incident Report for Cloudflare
Resolved
This incident is now resolved.
Posted Nov 18, 2024 - 20:53 UTC
Monitoring
A fix for this issue has been applied and we are currently monitoring the results.
Posted Nov 18, 2024 - 19:15 UTC
Identified
Custom certificates used for mTLS with customer origins fails to load. This issue will cause customer's origin servers to reject these connections due to lack of certificates. We are currently working on a fix for this issue.
Posted Nov 18, 2024 - 19:05 UTC
This incident affected: Cloudflare Sites and Services (CDN/Cache).