Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Magic Transit / Magic WAN Issues in ORD02 Colo
Incident Report for Cloudflare
Resolved
A small set of machines had exhausted memory for a control plane service. This may have impacted a subset of user traffic that had gone through that particular colo.
Posted Dec 16, 2024 - 18:35 UTC