Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Increased rate of connectivity errors in Türkiye region
Incident Report for Cloudflare
Resolved
Cloudflare is aware of an increased number of connectivity errors in the Türkiye region between 08:01 UTC and 08:11 UTC. Currently, some services in Türkiye are re-routed, which may cause increased latency in the region. The issue is identified, and we are working on a fix, which will be shown in our data center status list.
Posted Oct 17, 2024 - 08:30 UTC