Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
DEX Device Status delayed
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Oct 10, 2024 - 19:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 10, 2024 - 19:02 UTC
Investigating
DEX Device Status has seen a multi-hour delay in device_state consumption that is impacting all DEX users. Work is ongoing to discover the performance degradation and implement a fix.
Posted Oct 10, 2024 - 18:00 UTC
This incident affected: Cloudflare Sites and Services (Digital Experience Monitoring (DEX)).