Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Delays in transactional email delivery
Incident Report for Cloudflare
Update
A fix has been implemented, and we are actively monitoring the results.
Posted Oct 15, 2024 - 15:44 UTC
Monitoring
Cloudflare is investigating an issue causing transactional emails including password resets, 2fa codes and Access One Time Pins to be delayed.
Posted Oct 15, 2024 - 15:18 UTC
This incident affects: Cloudflare Sites and Services (Access).