Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:

Increased HTTP 530 Errors

Incident Report for Cloudflare

Resolved

Cloudflare is aware of reports of a limited number of customers seeing 530 errors on their custom hostnames. Action has been taken to resolve the problem and we have confirmed that impact has stopped. Investigation as to root cause will continue.
Posted Feb 22, 2025 - 11:58 UTC