Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Issues with Cloudflare Notifications
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Aug 30, 2024 - 16:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 30, 2024 - 16:09 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 30, 2024 - 15:54 UTC
Investigating
Cloudflare is investigating issues where customers may be unable to create certain alert types for Cloudflare notifications, or fail to receive them.
These issues do not affect the serving of cached files via the Cloudflare CDN or other security features at the Cloudflare Edge.
Posted Aug 30, 2024 - 15:46 UTC
This incident affected: Cloudflare Sites and Services (Notifications).