Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Issue with Workers Assets
Incident Report for Cloudflare
Resolved
Some customers using Workers Assets may have seen a portion of traffic return a "1104 Script Not Found" error page between 19:26 and 20:08 UTC.
Posted Dec 17, 2024 - 20:41 UTC