Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Cloud Connector displaying 403 errors
Incident Report for Cloudflare
Resolved
Cloudflare was aware of, and solved an issue where customers using Cloud Connector were seeing 403 errors. Cloudflare's dashboard operations should not have been affected despite errors shown.
Posted Oct 25, 2024 - 09:00 UTC