Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Issues with Bring Your Own IP (BYOIP) / Bring Your Own IP On-Demand feature
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Dec 05, 2024 - 22:53 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 05, 2024 - 22:16 UTC
Investigating
Cloudflare is investigating issues with Bring Your Own IP (BYOIP) / Bring Your Own IP (BYOIP) On-Demand feature. We are working to analyse and mitigate this problem. More updates to follow shortly. Impact is restricted to changes in the Bring Your Own IP (BYOIP) configuration and it does not affect any connectivity, security or CDN functionality.
Posted Dec 05, 2024 - 22:02 UTC
This incident affected: Cloudflare Sites and Services (Bring Your Own IP (BYOIP)).