Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Cloudflare Workers KV elevated time to consistency
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Sep 24, 2024 - 16:55 UTC
Investigating
Cloudflare is investigating elevated time to consistency for Workers KV, impacting keys uploaded and deleted via the bulk API endpoint.
We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Sep 24, 2024 - 13:41 UTC
This incident affected: Cloudflare Sites and Services (Workers KV).