Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Cloudflare Pages Build Issues
Incident Report for Cloudflare
Resolved
This incident is now resolved.
Posted Jan 21, 2025 - 17:56 UTC
Monitoring
The fix has been implemented and we are currently monitoring the results.
Posted Jan 21, 2025 - 17:44 UTC
Identified
Cloudflare is has identified an issue where Pages builds are failing. We are currently working on a fix for this issue.
Posted Jan 21, 2025 - 17:38 UTC
This incident affected: Cloudflare Sites and Services (Pages).