Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.
Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.
A fix is being released, and we are monitoring the results.
Posted Dec 05, 2024 - 15:13 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 05, 2024 - 11:02 UTC
Investigating
Cloudflare is aware of, and investigating an issue with Page Rules including Server Side Excludes which may be causing 500 errors on traffic. We are working on resolving the issue. Customers can remove the Server Side Excludes from Page Rules as a workaround in the meantime.
Posted Dec 05, 2024 - 10:35 UTC
This incident affected: Cloudflare Sites and Services (Rules).