Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Investigating reports of Zero Trust TLS Decryption cert being removed
Incident Report for Cloudflare
Resolved
We were able to identify the cause of this issue and apply an effective fix. This incident is now resolved.
Posted Oct 10, 2024 - 21:54 UTC
Investigating
We are investigating reports from customers with the WARP setting "Install CA to system certificate store" enabled that the root CA is being incorrectly removed from Windows devices.
Posted Oct 10, 2024 - 18:20 UTC
This incident affected: Cloudflare Sites and Services (WARP).