Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Network Performance Issues in Dallas, Texas
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Oct 26, 2024 - 03:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 26, 2024 - 03:01 UTC
Identified
The networking issue has been identified and we are diverting away traffic from the congestion.
Posted Oct 26, 2024 - 02:43 UTC
Investigating
Cloudflare is investigating issues with Network Performance in Dallas, Texas (DFW)

We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Oct 26, 2024 - 02:28 UTC
This incident affected: North America (Dallas, TX, United States - (DFW)).