Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:

CASB Google Workspace Findings Lag

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Feb 14, 2025 - 21:06 UTC

Monitoring

CASB team has identified root cause and implemented a fix in production. All Google Workspace integration findings lag is expected to be resolved within 24 hours. The team will continue monitoring.
Posted Feb 14, 2025 - 19:29 UTC

Investigating

CASB team is currently investigating a perceived issue wherein CASB is lagging behind on detecting findings for Google Workspace integrations. Team is actively investigating the root cause.
Posted Feb 14, 2025 - 18:11 UTC
This incident affected: Cloudflare Sites and Services (Cloud Access Security Broker (CASB)).