Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Lookups of RPKI resources are currently not functional
Incident Report for Cloudflare
Resolved
A fix was applied and this issue is now resolved.
Posted Jul 15, 2024 - 18:55 UTC
Investigating
Cloudflare is investigating issues with rpki.cloudflare.com as lookups of RPKI resources are currently not functional. Cloudflare is aware of the problem, and working on a fix.
Posted Jul 15, 2024 - 15:17 UTC
This incident affected: Cloudflare Sites and Services (Dashboard).