Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:

D1 Dashboard issues

Incident Report for Cloudflare

Resolved

Cloudflare is aware of an issue that impacted the D1 dashboard - users will not have been able to view tables, run queries or create databases. The issue has now been resolved.

Impact time was Feb 13th 23:54 - Feb 14th 00:51 UTC

Component: D1
Posted Feb 13, 2025 - 23:54 UTC