Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.
Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.
The fix has been implemented and we are currently monitoring the results.
Posted Feb 10, 2025 - 21:58 UTC
Identified
The cause of this issue has been identified and a fix is being implemented.
Posted Feb 10, 2025 - 20:41 UTC
Investigating
Cloudflare is experiencing problems in processing changes through our billing subscription service for Registrar services. All other services are operating normally.
We will provide an update once billing subscription services return to normal.
Posted Feb 10, 2025 - 17:05 UTC
This incident affected: Cloudflare Sites and Services (Billing).