Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Increase in HTTP 5XX Errors from Houston
Incident Report for Cloudflare
Resolved
Our investigation determined that these errors were not the result of an issue with our platform. This incident is now resolved.
Posted Aug 26, 2024 - 19:27 UTC
Investigating
We are investigating reports of an increase in HTTP 5XX errors associated with our Houston (IAH) datacenter.
Posted Aug 26, 2024 - 18:57 UTC
This incident affected: North America (Houston, TX, United States - (IAH)).