Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Cache Purging Delays in Some Regions
Incident Report for Cloudflare
Resolved
The cause of this issue was identified and an effective fix implemented. This issue is now resolved.
Posted Oct 01, 2024 - 17:33 UTC
Investigating
Cloudflare's cache purging called via the Dashboard/API is running up to 60 minutes behind in some regions.

We are working to resolve this issue as soon as possible. More updates to follow.
Posted Oct 01, 2024 - 14:15 UTC
This incident affected: Cloudflare Sites and Services (CDN Cache Purge).