Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Turnstile Analytics Degraded
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Oct 17, 2024 - 16:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 17, 2024 - 16:07 UTC
Identified
Turnstile may be experiencing missing events.
Posted Oct 17, 2024 - 16:06 UTC
This incident affected: Cloudflare Sites and Services (Turnstile).