Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Cloudflare Magic Wan: Migration issues
Incident Report for Cloudflare
Resolved
Cloudflare detected and mitigated an issue with Magic Wan on 2025-01-15 from 16:07 to 18:04 UTC: Customers with users on WARP-sourced traffic, that also use Magic Firewall, might have experienced functionality issues resulting in Magic Firewall packet filtering not occurring or potential connectivity issues. Impact was fully mitigated, and this behavior was only observed during the referenced timeframe.
Posted Jan 15, 2025 - 16:07 UTC