Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Cloudflare Pages project deletion errors
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 14:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 25, 2024 - 13:54 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 25, 2024 - 12:32 UTC
Investigating
Cloudflare is aware of and investigating an issue with Cloudflare Pages returning errors when attempting to delete projects. Further detail will be provided as more information becomes available.
Posted Jul 25, 2024 - 12:12 UTC
This incident affected: Cloudflare Sites and Services (Pages).