Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Support Ticket Migration - Case Access Issues
Incident Report for Cloudflare
Identified
We have identified an issue affecting our Pro and Business customers' ability to access their active cases. Our team is actively working on a fix to resolve this issue as quickly as possible. In the meantime, email must be used for case updates.
Posted Aug 02, 2024 - 20:48 UTC