Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Cache Purging Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 03, 2024 - 21:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2024 - 20:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 03, 2024 - 20:02 UTC
Investigating
Cloudflare single-file cache purging (purge by URL) called via the Dashboard/API is running up to a minute behind. This also affects the "Always Online" feature.

We are working to resolve this issue as soon as possible. More updates to follow.
Posted Jun 03, 2024 - 15:33 UTC
This incident affected: Cloudflare Sites and Services (CDN Cache Purge).