Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Network Performance Issues in Washington, DC (IAD)
Incident Report for Cloudflare
Resolved
Cloudflare observed increased latency and request errors for customers in Washington,DC (IAD) between 16:33 - 16:34 UTC

This incident has now been resolved.
Posted Jun 07, 2024 - 17:49 UTC
This incident affected: North America (Ashburn, VA, United States - (IAD)).