Unofficial and Honest Cloudflare System Status

Starting as early as at least 2022-10-26, users may experience a significant performance degradation when enabling HTTP/3 on their sites. Users are advised to disable HTTP/3 for better performance.

Update: Improvements have been made to HTTP/3 performance recently that greatly reduce the impact of this regression.


Sources:
Elevated number of 5xx errors in KUL (Kuala Lumpur)
Incident Report for Cloudflare
Resolved
Between 00:30-03:40 UTC on 30 May, customers reaching Kuala Lumpur, Malaysia would have experienced an elevated number of 5xx errors due to congestion.
Posted May 30, 2024 - 00:00 UTC